ผมมีปัญหาในการฝังซัพครับ

อยากรู้เรื่องเกี่ยวกับการใส่ซับไตเติ้ล การเพิ่มภาษา การปรับ timing และอื่นๆ เกี่ยวกับซับไตเติ้ล

Moderator: aot

ผมมีปัญหาในการฝังซัพครับ

Postby pangpond_GD » Fri Feb 01, 2013 8:03 pm

เวลาผมฝังซัพทีไร มันไม่ยอมขึ้นภาษาไทยสักที ขึ้นแต่ตัวแบบนี้ ใครรู้วิธีแก้ช่วยบอกด้วยนะครับ Image
pangpond_GD
 
Posts: 3
Joined: Fri Feb 01, 2013 7:36 pm

Postby aot » Fri Feb 01, 2013 11:10 pm

ตอบทีละข้อนะครับ

ไฟล์ซับนามสกุลอะไร ใช่ .ssa .ass หรือเปล่า

Encoding คุณตั้งเป็นอะไรครับ เพราะโดยปรกติเวลาฝังซับ
โปรแกรมแปลงหนังจะกำหนดให้การแสดงตัวหนังสือเป็น Default แต่ซับคุณอาจจะเป็น ANSI
หรือโปรแกรมอ่านตัวหนังสือซับแบบ ANSI แต่ไฟล์ซับคุณเซฟออกมาเป็น Default

^
^
งงๆ งงใช่มั้ยครับ

วิธีแก้สำหรับ .ssa ก็ไปที่โปรแกรมที่คุณใช้ดูไฟล์ซับแก้ไฟล์ซับ เช่น Subtitleworkshop เป็นต้น
ไปที่ setting > output setting > มองหาปุ่ม other แล้วมองหา Encoding แล้วเลือกเอาเลยครับ

วิธีแก้สำหรับ .ass ก็ไปที่โปรแกรมที่คุณใช้ดูไฟล์ซับแก้ไฟล์ซับ เช่น aegisup เป็นต้น
ไปที่ tools > styles manager > มองหาปุ่ม Default แล้วดับเบิ้ลคลิ๊กฝั่งขวา แล้วมองหา Encoding แล้วเลือกเอาเลยครับ
______________________________________________________________________

หรือ ไฟล์ ซับของคุณ เซฟไฟล์เป็น Encoding UTF-8 , Unicode หรืออะไรนอกจากนี้
วิธีแก้ให้เปิดไฟล์ซับด้วย notepad แล้วไปที่ file > save as > มองไปที่ Encoding แล้วเลือก ANSI แล้วเซฟได้เลย


หลังจากนั้นลองทดสอบเปิดดูในโปรแกรมแปลงไฟล์ฝังซับดูอีกที
aot
 
Posts: 813
Joined: Mon Sep 26, 2005 11:42 am
Location: http://www.facebook.com/Thaisubtitle4Free

Postby pangpond_GD » Sat Feb 02, 2013 1:37 pm

ขอบคุณครับ จะลองแก้ดู
pangpond_GD
 
Posts: 3
Joined: Fri Feb 01, 2013 7:36 pm

Postby pangpond_GD » Sat Feb 02, 2013 2:37 pm

ตัวอักษรขึ้นแล้วครับ แต่มันก็ยังมีสี่เหลี่ยมเหมือนเดิม :cry:
pangpond_GD
 
Posts: 3
Joined: Fri Feb 01, 2013 7:36 pm


Return to Subtitle Technique

Who is online

Users browsing this forum: No registered users and 1 guest

cron